1. IronSource Offerings; the rise of civilization, 0,99 $ in-app purchasing task. 855 the money didn't go into my account.

    2.I Joined to Facebook, but 10 the money didn't go into my account.

    3.I Joined to Mail and Actived, but 1 the money didn't go into my account.

  • @mse888 Hey 🤝 !

    Some of the reasons for why you might not receive your reward are the following:

    • You might have installed Lords Mobile at least ONCE already (even if it is 1 or 2 years ago) so the system will recognize that it is your phone or you have tried to install the game before.

    • You might have tried similar offers on different games that involved the installment of Lords Mobile, thus it is not giving you the reward on OSM now.
      Your IP is identical ( but someone else from your network has completed this offer)
      Same Apple ID or PlayStore user trying to do the offers again, this might be one of the reasons that you aren't receiving the reward too. You probably tried it on an iPhone and now you're doing it with an Android or vice-versa.

    • Time limitation: This is usually not known but you have a specific time to finish your task. Personally I never knew how much time you get for finishing this.
      Wrongfully clicked more than two LORDS MOBILE offers, if this happens the game will not reward you.

    • 48 hour delay - some offers take up to 48 or 72 hours to give you the reward, if you do not receive it by now then something else is wrong.

    If you're 100% sure that none of the above has happened to you then you must send an e-mail to the one that is providing the offer to you. You must provide proof to them that you have finished the offer but the coins are not being rewarded to you. You must also provide them with a special code that is assigned to your account depending on which platform you completed the offer, you find the support team e-mail and let them know everything.